Disclaimer: All work shared in this post is property of ©2012 Soul Dev Team. Anybody wishing to share this work is freely allowed to, provided they give credit to the original creators, and link back to this post.

As promised a day or so ago, here’s an updated Mountain Lion image since we didn’t bring out anything for DP2/DP3 (it wasn’t worth the effort). However, this has enough changes between DP1 and so here it is. The OS X Mountain Lion 10.8 DP4 VMware Image an installation of Developer Preview 4 which was released a few days back following Apple’s WWDC keynote. Any system bugs you encounter are most likely due to Apple because at the end of the day, this is a beta. As such, I’d like to make it clear that any issues you discover with this, you’re on your own (unless it’s something basic), seeing as it’s just not worth maintaining like the retail builds of Lion etc. The good news that comes along with this release is that I’ve got some stuff sorted which should work with the Retail release when it becomes available in July, and as such the Retail build should come along fairly quickly (and by Retail, I do not mean the GM build). Make sure to read the notes below, then just follow the video below them, and download links are underneath the video (both a torrent download and direct downloads).
 

OS X Mountain Lion DP4 VMware Image Changelog ---------------------------------------------- - Apple dropped support for 32-bit mode in DP2 of Mountain Lion, so make sure you keep the VMware Settings flagged as "Mac OS X 10.7 64-bit" otherwise no bootable medium will be detected. We are currently working on a workaround for this. - Comes with direct download links as usual, should be faster this time. - Completely Vanilla build. Drivers are purely patched Apple files. - Continued new packaging for smaller download. - Fresh installation of 10.8 DP4, everything was fixed during installation. - Make sure VT is turned on in your BIOS, if available. - No comment on AMD systems. Same applies as previously mentioned here. - Reasonably quick boot time, about 1 minute 15 seconds on average. - Recommended you run on the latest version of VMware, as that's what it was tested on, and apparently fixes Apple logo stalling. - Several driver patches to allow as best a universal build as possible. - Snappier system. Clicks receive response almost (if not) instantaneously. - We uploaded an updated VMware Tools to our Mediafire folder here. Hopefully these should work better than in the last 10.8 image.

As you can see, there are a bunch of changes in this build even if not all have been included. Underneath you can find the setup guide video to show you how it all needs to be setup for it to work correctly. It’s important you take note, because we won’t answer any questions that are already answered in the video:

If you wish to download the OS X Mountain Lion 10.8 DP4 VMware Image via torrent, you can just click here. As promised, I’m including direct links as well this time around, but you’ll have to deal with the fact that they will be slower than the torrent, even though I have now paid for faster speeds. You can find the direct links here.

103 Responses so far.

  1. sHARAF says:

    i hope this work
    as with 10.7.4 and 10.7.3 i got error
    in boot after apple logo i got apple disappeared and locked nothing more
    the only one worked with me was 10.7
    then after update with combo to 10.7.4 and apply patch bu you
    i got the same lock
    i have t520 thinkpad i5 2520 with 6g of ram – intel hd 3000

    thx i am waiting this one

  2. gogogo says:

    Thanks for this. It works flawlessly on my Ivy Bridge computer with sound. However the resolution cannot be changed on my installation, only 1024×768

    I have the opposite problem with your Snow Leopard final. The resolution was fine but the sound wasn’t working. Like the poster above, I couldn’t get any of your Lion versions to work on my computer.

    In any case I’m very impressed with your work and Mountain Lion itself. Everything feels snappy and things work smoothly so far.

    • ZackehSoul says:

      Try the VMware Tools. In Snow Leopard install Ensoniq.

      • gogogo says:

        Thanks for the suggestions. But unfortunatly the VMware tools keep failing while installation, both the one included in the download and the one from Mediafire :(

      • Steve says:

        I found even though it said it failed, when I rebooted the guest I found that the tools were actually installed (my mouse past from host to guest without ctrl + alt)

        Also found with my ivy bridge board+cpu (i7-3770 and Asus P8Z777-V-LX) to stop the dam annoying “GuestOS has Disabled the CPU” error. I added this to the .vmx file (without the quotes)

        “cpuid.1.eax = 0000:0000:0000:0001:0000:0110:1010:0101″

        it works and is stable Zackehsoul I notice a LOT of people keep ahhh “asking” (bitching) on getting you to fix this so thought it might be helpful for ya ;-)

        • paul says:

          I used the same in my VMX file , but have still the same error.
          any ideas to try?
          i have AMD Phenom II X6 1090T processor
          virtualisation enabled in bios.

          would be very happy to get it to work..

  3. levay says:

    hey there, thanks for this!

    i was wondering whether quartz composer will work with this release?

    i have an msi gtx560ti twin frozr graphics card (which i’ve not been able to get working with your previous releases), and also i wont be able to connect the machine running the vmware image to the net so i’ll be installing the last version of xcode which was available as a disk image.

    could you please tell me if this version will have the same issues in utilising my graphics card (i.e. will it be possible to enable QE/CI?)

    thanks again for all your efforts, i very much appreciate it :)

  4. Joao says:

    Hi! thanks for this awesome share

    I have a AMD cpu you think i can install it and use it?
    Please appreciate reply

    Great work

  5. drmrps says:

    hello zack I wanted to know if you have a video showing how to install vmware and what I need to do to run your images on it. or if you could show me other video on youtube or some site that does that. thank you

  6. Jure says:

    Hi! Have you managed to install vmware tools (darwin.iso)? During installation (validating packagtes) throws an error “The installer encountered an error …”. Any ideas? Thanks =)

  7. noah says:

    I have 10.7.3 working with no issues. I got 10.8 working but vmware tools errors during installation. Any ideas?

    I can supply you the error after work if you need it.

    Thanks for the build, I am eager to get it full resolution and fully functional!

  8. Chetan Hireholi says:

    Thanks Zack for the work you put up, really appreciate it.

    I followed the whole procedure out there in my PC, but during the running the file on the VMware Workstation, the OS is not booting up.

    It shows the “Apple” symbol, but after that, it just halts rather stops over there completely.

    Could you certainly please help me out in this case…

    Thank You

    Chetan Hireholi (chetan.hireholi@gmail.com)

  9. TechXero says:

    Ok, first let me thank you for your awesome work !

    And, guess what, after a few failed tries it worked like a charm, I only got like 4gigs of RAM n a slow Q9550 QuadCore system from 2008 !

    Other than that, I just have one complaint, that is the sound, it works n all but barely, it takes 2 to 3 secs to play a less than a sec push notification sound, it is scratchy if you get my drift !

    Oh and thanks for VMWare Tools, old Lion ones caused a KP yours worked like a charm !

    Finally I would like to mention that I loved your post so much it’s on my site now with obviously a link-back to this post ;)

    Keep up the great work, and I await an answer to my issue soon …

    Thanks a ton.
    TechXero

    • ZackehSoul says:

      Have you tried installing Ensoniq Audio? And you used the Tech Preview version of the Tools? :)

      • TechXero says:

        Yes I sure did on both things .. still too buggy ! Buffering audio … And btw thanks again on the Flash fix worked great !

        Though I agree that VMWare is for urgency only not to use as main OS still I have found myself using ML/L more than my main OS just coz it’s MacOS for God sake ! Beats windows any day !!!

        Thanks again ;)

        • ZackehSoul says:

          Well we’re working on install stuff for native, but we can’t afford another test laptop (which we need). So until we get that up and running, we’re VM only for ML

  10. JT says:

    Hi folks

    i am using this OS in VMware 8 and is working great!

    Only one thing i cannot do is i cannot execute any software such as utorrent or simple vlc player!!!

    it says that is not trustable software and the execution can not proceed!

    so how can i install a torrent software on this OS?

    cheers

  11. brodson says:

    Hey, I got it working but when I try and install VMware tools, it says the installation fails. Any idea why this may be?

  12. emm says:

    this FINALLY works for me! I have not been successful with any releases since 10.6.8 for whatever reasons. I have been so frustrated. I7 windows 7. Haven’t been able to get it working! Now this finally works! YIPPIE!!!!

  13. emm says:

    well I spoke too soon. It installs and loads up fine. But it locks up after about 5 minutes. I was so happy it was finally working! Back to square one!

  14. AnhDuyVo says:

    I tried to install it. The system boot fine but my keyboard didn’t work. How can I fix it?

  15. bummpr says:

    I also got errors on install of VMWare Tools but after reboot the screen resolution fix worked fine. However I get an error on shutdown of Mountain Lion every time…then on reboot, I’m asked to wait for a recovery process and if I want to send an error report. I’ve never had a problem with Zack’s releases before.

  16. mvb says:

    Hi Zackeh,

    You machines are very good they work very well. But you should look for Netbeans and Intellij Idea. As I told you before these applications have problems with the mouse.
    They work perfectly in my Snow Leopard but in your machines they have simple problems like opening a java class. You must double click in the file in the project explorer but it does not work.
    Maybe this is a simple problem. But I cannot find the solution. I think this can be a problem with VMWare Tools, but I am not sure.
    I have downloaded this Mountain Lion and installed the new VMware Tools and it did not work, I have installed the VMWare Tools in Lion 10.7.3 and it did not work too.
    It works in all application except for these two, but they are very important for those the work in development.
    If you could look at this problem, it would be great.
    Thanks

    • ZackehSoul says:

      It’s only those two? And does clicking completely fail?

      • Mvb says:

        Yes, it is incredible but these are the only programs that present this problem. Eclipse works very well.
        I thought it could be the Vmware tools but i dont know. I have e tried with th new tech preview and it did not workeed. But it workd in my Snow Leopard.

        Thanks

  17. forman says:

    This is amazing, but I can’t run it! It talk about long mode and then something about running in 64 bits mode and if I press yes, it shut down.

  18. Fq says:

    First of all, thank you so much for everything. You must had spent endless hours on creating this for everyone. Thank you again.

    I been trying to use this since Lion 10.7.3, but it doesn’t seem to work. On my desktop with VT support, it work flawlessly, but I travel alot so I want it to work on my Sony Vaio laptop.

    On Lion 10.7.3, when I first boot it, I constantly getting a stop sign after starting the Virtual Machine. at first, I thought it was the Windows x64 itself so I reinstall it with x86 bit Windows. Still, it doesn’t work. So I try upgrading 8.0.1 to Vmware 8.0.3 and it still doesn’t work. However, when I reinstall windows, it started popping out this message “Long Mode”.

    So I tried Mountain Lion which is this version and this is what happened: “This Virtual Machine is configured for 64-bit guest operating systems. However, 64-bit operation is not possible. This host does not support VT. Continue without 64-bit support?” Both yes or no will stop the machine. If I edit virtual machine settings and change it from x64 bit to non x64 bit, it again show the stop sign. If I attempt to go to verbose mode in the non x64 bit mode, it shows this: “This version of Mac OS X iss not supported on this platform. Reason: Unsupported 32-bit-only”

    This is after applying VMware Unlocker and the bypasser for every update. I reinstall the software about 20 times, so it’s not VMware.

    Please help and thank you so much in advance. I been working on this for days now!

    • ZackehSoul says:

      It requires 64-bit, Mountain Lion can’t run in 32-bit because Apple removed the ability for it to do so (for some random reason). The bypasser isn’t working? That’s odd. Did it seem to run properly when you used it?

  19. Guy says:

    I’ve installed Lion 10.8.4 on wmware workstation 8 on a windows 7 machine. When I try to install wmware tools I get the error: ‘Could not find component on update server. Contact VMware Support or your system administrator’. I also try to install in the Lion guest but I’m also getting an eror. How can I fix this?

  20. one8seven says:

    Thanks for the work and share!

    One question : is there a possiblity to change the resolution to have a proper full screen view?
    I can only find a “stretch-view” option in VMWARE but that reduces the image quality.

  21. one8seven says:

    I need to have an option to change my resolution to 1920 x 1080. When I try to manually change it in VMWARE it just pops back to the original setting

  22. canadrian says:

    Any chance of getting this working on ESXi?

  23. Sandeep says:

    After a few tries with vmware tools, it installs. So all be patient and restart the vm a couple of times, after say the 4th time, vmware tools will get installed :) .
    It will give an installation failed error, but the installer has installed properly.

    Sandeep

  24. Drmrps says:

    hello zack I wanted to know if you have a video showing how to install vmware and what I need to do to run your images on it. or if you could show me other video on youtube or some site that does that. thank you
    Reply

    • ZackehSoul says:

      I’ll post one soon, I’m getting ready to leave for the US, but I should have one posted before I leave :)

  25. TechXero says:

    Just updated to 12A256 which killed it for me ! As soon as I set up SMC Present=”FALSE” it boots just fine just no keyboard or mouse !!!!

    I exhausted all my expertise and internet looking for a solution to no avail !

    I got Lion working so if it’s a matter of Kexts point me to the ones to use and I will mount the ML VMDK in Lion and install from there xD

    HELP !!!

  26. vishy says:

    are there any vmware tools available for this build as in the case of your lion build? ur builds rock btw and i love using the lion build :D

    • ZackehSoul says:

      The Tech Preview tools from here should work, but it may take a few attempts to get them to install. Apparently it installs even if the installer fails.

  27. Gman says:

    Thanks for this! I had (still have) some problems with 10.7.4 on VM Workstation… but this one works flawlessly.

  28. v says:

    Hi zack, mountain lion is working in vmware 8.4.thanks

    could you help me with the below issues

    1,the resolution is only 1024×768 .how to increase this? i used lion and it had highresolution.
    2,VM doesn’t shutdown. it complain something about the shutdown and restart again?

    regards
    v

  29. JbRbV says:

    I installed this ML DP4 version alongside your Lion 10.7.4 and it works well apart from a few faults of which i’m not sure where the fault lies.
    If i try to start launchpad it takes one to two minutes during which the VM is frozen. The same if want to go back from LaunchPad.
    After i stopped and start or restart i get the your computer has restarted message. I can continue though. I’m running Win7-64 with VMw wks 8.0.2 with unlocker and bypasser. Are there any solutiobs available?

  30. miron89 says:

    someone can confirm this version working with Xcode?
    thnx

    • ZackehSoul says:

      Yep, XCode is nothing special.

      • Miron89 says:

        I heard some people get their apple I.d marked
        Or banned from all apple services cause they
        Use osx with VMware. How can I avoid this ban
        I just wanna use the Xcode.?
        Thanx

        • ZackehSoul says:

          That’s untrue as far as I’m aware. Don’t register, just use your account in the App Store to get XCode, then sign out of it if you’re worried.

          • miron89 says:

            xcode doesn’t working on this version (yet)
            when you try to download it from the appstore it’s says that youre osx is too new :)

            • ZackehSoul says:

              That’s because you’re on Beta software, only the XCode Betas work alongside it :) After the Retail version is out, XCode will be fine.

  31. Julian Zhou says:

    Hi Zach, I have the problem during shutdown.. Everytime I reboot it tells me that the system was shutdown because of a problem. Is that normal, or should I ignore it?

  32. MrBonk says:

    Hey mate. Just wanted to say thanks for the info and downloads to get this working. I tried to install the VMware tools, but the installation kept telling me it had failed. However, after a reboot I can see that it has successfully added the resolution options to the Display section (which is all I really wanted the tools for).

    The only problem I have is I get an error when I shut the VM down which says that my virtual CPU has encountered a fault and entered a shutdown state. Doesn’t seem to make any difference though….I’m able to boot it up fine next time and just ignore the ‘your machine shut down unexpectedly’ errors.

    Cheers again,
    MrBonk

    • ZackehSoul says:

      Yeah the installer fails but still installs the components (if that makes any sense at all). As for the shutdown thing, although it’s quite annoying for restarts it’s not actually a problem because it won’t affect anything/break your system.

  33. Stan says:

    i can”t install intel hd 4000 kext file does anyone help me ? i want to change screen res. but it fixed to 1024×768 , i need help :(

    Cpu : i7 3770K
    Mobo: asrock z77 extrem 4

  34. Robb says:

    Update: After waiting nearly 10 minutes, everything did finally come up. I am hoping it was just doing an update or something and this won’t be the norm every time!

    Great work on everything!

  35. marina says:

    Hey Zach, amazing work! I am encountering problems with imessege.. not sure if it’s suppose to work or not but i cannot sign in.. says i am not able to sign in. try again later. Know anything of this?

    Thanks in advance! Cheers!

  36. Tico says:

    Thanks man! You are the man!

  37. Peter says:

    Thanks A Lot..

    Working Perfectly on Core i5 3210M Cpu..

  38. Lenkun says:

    I am trying to create my own 10.8 GM on VMWare and was able to install it. However, the boot time and shutdown time is extremely slow and runs very very sluggish. Was wondering what or how you created your 10.8 DP4 to run so smooth on VM?

    10.7.x runs smooth for me, but 10.8 causes my VM and even my host to run like a snail. Did you have to change some permission or maybe replace some Kext? If so, which version and how did you accomplish that?

    • ZackehSoul says:

      Try replacing AppleSMC.kext, that sounds like your issue.

      • Lenkun says:

        Thanks, but what version of the AppleSMC.kext did you use? I used the Kext Wizard to do a repair with 10.7.4 kext for 10.8, but that didn’t work. Still ran sluggish.

        I checked your site http://www.mediafire.com/zackehsoul but didn’t see any AppleSMC.kext uploaded. Can you please share the AppleSMC.kext you used for creating your 10.8 DP Mountain Lion VM?

        • ZackehSoul says:

          I didn’t use one, but that’s what’s causing your issue. The same issue exists on 10.7.4, so you need 10.7.3 or lower.

  39. GT says:

    Hi Zack ,,, must thanks for ur amazing work , i had just downloaded your vmimage for 10.8 and is stuck with issue which does not allow me to use any of the Apple id for icloud and facetime ,when i try to use my apple id i got text saying that this devices is not elgible for use of apple id ..
    any clude what could be wrong and how can we fix it ,,, thanks

  40. darkwolfz says:

    Great work !

  41. Abdul Basit says:

    Hello Zackhsoul can this work’s on windows 7 Ultimate x86 (32-bit)
    Please Tell Me

  42. dude says:

    I use vmware workstation 9 and used the “OS X 10.8 Mountain Lion Retail VMware Image”.
    I tried download “Install VMware Tools (Tech Preview)”
    I dont know how to install that downloaded stuff,any help?

    I get “Could not find component on update server. Contact Vmware Support or your system administrator.”

  43. Nico says:

    Finally got the sound working perfect after some restarts! :)

  44. Wil says:

    Problem: Graphics lag / Window movement noticeable lag

    Specs : VMware 9.0.1 , OS X 10.8.2 Asus Intel CPU 4Core , 8 Gb of Ram , using on board Intel video.

    I answeared my own question..
    Installing VMSvga2 V1.2.5_os_10.6-10.8.pkg
    fixed the lag and made it run smoother with VM in window.

    http://sourceforge.net/projects/vmsvga2/files/Display/VMsvga2_v1.2.5_OS_10.6-10.8.pkg/download?use_mirror=superb-dca3&r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fvmsvga2%2F&use_mirror=superb-dca3

    Hope this help anyone else..

    Cheers..

  45. Nilesh says:

    Can i use xcode for development?

  46. HArryHarry says:

    Hey There. Can I install this on a macbook Pro air, with os x lion? if it is possible, I would be really grateful if you told me how to. I’m kind of a nooby at this.


  • RSS
  • Facebook
  • Twitter
  • Youtube